Collapse headers within markdown cell

We should be able to collapse sections of code from the header in a markdown cell, as opposed to only being able to use a header cell. An example use case for this is if there's text that we want to always be visible below the header, while still having the option to collapse cells below the markdown.

This would also expand the collapsible workflow to shortcut-heavy and markdown-heavy users, such as myself.

I assume a similar implementation to Colab would be acceptable for most users, where collapse nesting/priority is determined by the first header present in the markdown cell.

Visuals within headers reload on every collapse

Every time the code cells below a header are collapsed and then expanded, any cells that produced a visual (such as one from seaborn or plotly) are blank for a moment before re-loading the visual. This is very similar to the reloading that would happen every time a new cell was inserted into the notebook, before that bug got fixed.

Collapsible headers break when nested

Title. If I use a Header 1, have some code cells, and then put a header 3, the header 1 will encompass everything, including the header 3 (as expected), but clicking the arrow to collapse the header 3 no longer does anything.

np.datetime64('NaT') prevents rich dataframe output

Title. Example code:

import numpy as np
import pandas as pd
df1 = pd.DataFrame(columns=['x', 'y', 'z'], data={'x':[1], 'y':['a'], 'z':[np.datetime64('2000-01-01')]})
df2 = pd.DataFrame(columns=['x', 'y', 'z'], data={'x':[1], 'y':['a'], 'z':[np.datetime64('NaT')]})

Viewing df1, despite histogram warnings, displays the rich Deepnote dataframe output that I've come to know + love:
However, the df2 has no "Preview" option and always gives raw output:
ο»ΏUsing the following code, though, it's clear that they're both dataframes:


Machine doesn't turn on after restart

After I click "restart" machine, the machine doesn't actually restart--it just turns off. I have to then manually turn it back on my clicking "start".

I also noticed that my project machines used to turn on automatically when I opened them from my dashboard, but now I have to manually turn them on every time I open them.Β 
Like Comment

Cell doesn't run updated version of code

I'm having an issue where after I change the code in a cell to fix an error, the error persists and the line of code the error refers to is the oldΒ  version.

For example: let's say I'm working with a dataframe called df. I want to preview the column named "numbers", so I use the following code:


I obviously get the following error:

AttributeError: 'DataFrame' object has no attribute 'numers'

I then fix the typo, and run the following code in the same cell:


However, I get the same error referring to the old, unchanged code:

AttributeError: 'DataFrame' object has no attribute 'numers'

If I copy the code to a new cell, I no longer get the error.Β 

How to use selenium in Deepnote?

Title. I've been trying to follow the guide here, but I keep getting the following error:

Message: unknown error: Chrome failed to start: exited abnormally.
Β  (unknown error: DevToolsActivePort file doesn't exist)
Β  (The process started from chrome location /usr/bin/chromium is no longer running, so ChromeDriver is assuming that Chrome has crashed.)

When I check the init.ipynb, I see the following line:

chromium-driver is already the newest version (83.0.4103.116-1~deb10u3).

I'm thinking that this may be the issue, since when I check on the chromium website, the latest verison is 87 (and Chrome itself is at version 87 as well).Β 

I tried manually downloading the chromedriver.exe from the site, putting it in the project, and passing it through executable_path, but the notebook doesn't seem to be able to recognize it.

How can I use selenium in Deepnote? Any help would be appreciated.

Ability to upload folders

Being able to only upload files (as opposed to folders) is quite limiting and can make Deepnote really hard to use, forcing me to use Jupyter instead.
Like Comment